[通达信公式]通达信MACD+KDJ+RSI三合一指标公式 牛股攻击指标

来源:沃指南网

MACD+KDJ+RSI三合一指标公式 牛股攻击指标怎么用

通达信MACD+KDJ+RSI三合一指标公式 牛股攻击指标

三合一指标公式是集MACD、KDJ、RSI三个指标精华于一体的综合研判指标,如下图,红色彩带低位金叉开始买入股票持股待涨,直到零轴红柱开始缩短短线卖出。如果零轴上方出现二次金叉上涨动力增强,可重仓介入。另外参数上顶背离(卖出)、底背离(买入)提示。

MACD+KDJ+RSI三合一指标公式 牛股攻击指标源码

DIFF1:EMA(CLOSE,12) - EMA(CLOSE,26);

DEA1 :EMA(DIFF1,9);

DIFF77:= EMA(CLOSE,12) - EMA(CLOSE,26);

DEA77:= EMA(DIFF77,9);

牛股攻击 : 2*(DIFF77-DEA77), COLORSTICK;

STICKLINE(牛股攻击>REF(牛股攻击,1) AND DIFF77>DEA77,牛股攻击,0,3,0),COLORRED;

STICKLINE(牛股攻击>REF(牛股攻击,1) AND DIFF77>DEA77,牛股攻击,0,1,0),COLORYELLOW;

DRAWBAND(DEA1,DRAWNULL,DIFF1,RGB(250,0,0));

DIFF:DIFF1,COLORWHITE;

DEA:DEA1,COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);

A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));

B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));

B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));

C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));

D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);

C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));

D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));

C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));

D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));

MACD底背:IF(B1>0,-0.1,0),COLORRED,POINTDOT;

KDJ底背:IF(B2>0,-0.1,0),COLORFF00FF,POINTDOT;

RSI底背:IF(B3>0,-0.1,0),COLORYELLOW,POINTDOT;

MACD顶背:IF(D1>0,0.1,0),COLOR00FF00,POINTDOT;

KDJ顶背:IF(D2>0,0.1,0),COLORFFCC66,POINTDOT;

RSI顶背:IF(D3>0,0.1,0),COLORWHITE,POINTDOT;

STICKLINE(B1>0,-0.04,0,3,0),COLORRED,LINETHICK3;

STICKLINE(B2>0,-0.04,0,3,0),COLORFF00FF,LINETHICK5;

STICKLINE(B3>0,-0.04,0,3,0),COLORYELLOW,LINETHICK5;

STICKLINE(D1>0,0.04,0,3,0),COLOR00FF00,LINETHICK5;

STICKLINE(D2>0,0.04,0,3,0),COLORFFCC66,LINETHICK5;

STICKLINE(D3>0,0.04,0,3,0),COLORWHITE,LINETHICK5;

{以上通达信公式你们学会怎么用了吗,如果你还想了解更多更多通达信公式指标,欢迎及时关注沃指南网(www.oznw.com)}

通达信公式更多分享